Linux:WordPress 默认主题存在跨站攻击漏洞

IT 评论 scott 264℃ 0评论

根据外媒arstechnica援引国外安全研究机构sucuri.net的报告称,WordPress的默认主题TwentyFourteen存在跨站攻击漏洞。此漏洞允许攻击者使用该主题内置的一个ico图标生成文件(genericons)来进行攻击,研究机构称,漏洞来自此ico图标生成文件,所以任何应用了此功能的主题或者插件都受到了影响,目前已知的有默认主题TwentyFourteen和插件jetpack(安装次数超过100万)受此影响。

Linux:WordPress 默认主题存在跨站攻击漏洞

Linux:WordPress 默认主题存在跨站攻击漏洞

漏洞文件

该漏洞的验证地址如下:RPKhot-227安全人员建议开启网站防火墙的WAF攻击防御措施来抵御此攻击。当然彻底修复该漏洞的方法也很简单,直接删除目录genericons即可避免。

Linux:WordPress 默认主题存在跨站攻击漏洞

Linux:WordPress 默认主题存在跨站攻击漏洞

漏洞演示 

目前GoDaddy、DreamHost等主机商和公司已经主动修复该漏洞,但截至发稿前从官方网站下载的最新版WordPress 4.2.1依然存在此目录和漏洞。

 

来源:http://www.rpk31.com/778.html

转载请注明:osetc.com » Linux:WordPress 默认主题存在跨站攻击漏洞

喜欢 (1)or分享 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址